Issue Impacting Site Access and Performance

Postmortem

Incident Summary
On Monday, July 6, some clients experienced intermittent slowness and connectivity issues while accessing the platform. Our support team received the first reports at 9:51 AM ET. Our team immediately began an investigation and identified the cause as an issue within our network failover mechanism. The issue was resolved at 2:05 PM ET.

Impact

  • Page loading times were unpredictable and slow.
  • Access to features requiring authentication may have been disrupted or inconsistent.
  • No data loss occurred as a result of this incident.

Root Cause
Investigation traced the issue to a failure in the network's high-availability failover mechanism. As a result, a backup network device briefly began responding to traffic alongside the primary device, creating a conflict that caused unpredictable routing and dropped connections for affected clients.

Resolution
The backup device was taken offline and restarted in a controlled manner. Following this action, the underlying errors cleared, network routing stabilized, and platform performance returned to normal.

Posted Jul 08, 2026 - 15:37 EDT

Resolved

The performance issue affecting sites has been resolved. All systems are operating normally.

We appreciate your patience!
Posted Jul 06, 2026 - 15:40 EDT

Monitoring

A fix has been implemented and functionality is returning to normal. We are actively monitoring performance to ensure stability.

If you continue to experience issues, please contact our support team.
Posted Jul 06, 2026 - 14:53 EDT

Identified

We have identified the issue impacting our production sites. Our team is actively implementing a fix to restore site performance!

We will continue to provide updates as progress is made.
Posted Jul 06, 2026 - 14:26 EDT

Update

We continue to investigate this issue. At this time, impact appears to be intermittent and is not affecting all sites. Our team continues to work to identify the cause, and we will post another update within the hour.
Posted Jul 06, 2026 - 13:26 EDT

Investigating

We are currently investigating reports of slowness affecting sites. Some users may be experiencing difficulty logging in or loading pages.

Our team is actively working to determine the cause and will provide an update as soon as more information is available.
Posted Jul 06, 2026 - 12:21 EDT
This incident affected: Assessment Management Production Sites (Site Access and Performance).